jQuery

最新更新: 2018-09-07 09:56:53 阅读: 45次

目前jQuery兼容于所有主流浏览器, 包括Internet Explorer 6!


jQuery 版本 2 以上不支持 IE6,7,8 浏览器。

如果需要支持 IE6/7/8,那么请选择1.9

你还可以通过条件注释在使用 IE6/7/8 时只包含进1.9。

<!--[if lt IE 9]> <script src="jquery-1.9.0.js"></script> <![endif]--> <!--[if gte IE 9]><!--> <script src="jquery-2.0.0.js"></script> <!--<![endif]-->


如果您不希望下载并存放 jQuery,那么也可以通过 CDN(内容分发网络) 引用它。

BootCDN、百度、又拍云、新浪、谷歌和微软的服务器都存有 jQuery 。

如果你的站点用户是国内的,建议使用百度、又拍云、新浪等国内CDN地址,如果你站点用户是国外的可以使用谷歌和微软。




BootCDN:

<head><scriptsrc="https://cdn.bootcss.com/jquery/1.10.2/jquery.min.js"></script></head>

百度 CDN:
<head><scriptsrc="https://apps.bdimg.com/libs/jquery/2.1.4/jquery.min.js"></script></head>


又拍云 CDN:
<head><scriptsrc="http://upcdn.b0.upaiyun.com/libs/jquery/jquery-2.0.2.min.js"></script></head>
新浪 CDN:
<head><scriptsrc="http://lib.sinaapp.com/js/jquery/2.0.2/jquery-2.0.2.min.js"></script></head>


Google CDN:
<head><scriptsrc="http://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js"></script></head>



lamp 不大推荐使用Google CDN来获取版本,因为Google产品在中国很不稳定。
Microsoft CDN:


没有jQuery,就引入jQuery 

<script>window.jQuery || document.write('<script src="js/jquery-1.11.0.min.js"></script>')</script>